gbn2r56
27.06.2021 10:50

Написать программу на паскале авс. дана строка,в которой есть точки,запятые,пробелы,тире,слова. в общем,много-много всего. нужно преобразовать строку по правилам ворда. то есть 1.между словами один пробел 2.перед точкой или запятой пробела нет,но после-есть 3. тире выделяется пробелами с двух сторон вот и все!

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
GoodSmileEweryDay
03.10.2020 20:27
Var s,s1:string; i,p:integer;
begin
writeln('Введите строку:');
readln(s);
s1:='';
for i:=1 to length(s) do
 case s[i] of
 ',','.' : s1:=s1+s[i]+' ';
 '-'     : s1:=s1+' - ';
 else s1:=s1+s[i];
 end;
p:=pos('  ',s1);
while p>0 do
 begin delete(s1,p,1); p:=pos('  ',s1); end;
p:=pos(' ,',s1);
while p>0 do
 begin delete(s1,p,1); p:=pos(' ,',s1); end;
p:=pos(' .',s1);
while p>0 do
 begin delete(s1,p,1); p:=pos(' .',s1); end; 
writeln(s1);
end.

Пример:
Введите строку:
перед точкой   или   запятой пробела нет   ,но после   -есть   .
перед точкой или запятой пробела нет, но после - есть. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота