kakashonka1
03.05.2022 14:10

Нарисуйте блок-схему и напишите программу вывода на экран большего из двух чисел. Примечания: числа могут быть дробными

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
goodwar40
23.07.2021 11:33

Компьютер, прежде всего, победил пишущую машинку, потому что стал думающей, интеллектуальной пишущей машинкой. Он взял все функции старой пишущей машинки и добавил к ним еще одну — он научился прощать людям их ошибки при работе с текстом. А традиционная пишущая машинка им таких ошибок не прощала.

Вначале вообще появились однофункциональные электронные машины — текстовые процессоры. Это были компьютеры, умеющие работать только с текстом. Однако затем появились универсальные ПК выполнять и множество других приложений, обеспечивающие совместимость множества программ, в ряду которых были и собственно текстовые процессоры - программы, позволяющие использовать компьютер для манипуляций с текстом, в том числе и с формулами: печатать текст, переворачивать его как угодно, переставлять слова, предложения, абзацы, вставлять и удалять любые куски текста и знаки препинания и, в конце концов распечатывать текст на бумаге посредством принтера. Самый известный текстовый процессор (то есть самая известная программа для обработки текста и формул) — MS WORD . Есть и другие, например Works, Лексикон.

После возможности обработки текста компьютер получил обработки таблиц. Появилась программа MS EXCEL (переводится как "непревзойденный", "превосходный"), появилась программа LOTUS 1-2-3.

От обработки таблиц компьютер перешел к обработке картинок, чертежей, звука и изображения и вообще научился писать и выпускать книги и рисовать целые картины, делать фильмы и обрабатывать музыку. Можно записать свой голос с какими-либо словами, а затем пустить его наоборот, или сделать с эхом, как будто вы находитесь в горах или в пещере, возможны вообще любые манипуляции. Компьютер стал инструментом дизайнера, художника и артиста. Появились программы PageMaker (создание макетов книг и печать), Adobe Photoshop (цветоделение и обработка изображений), Quark Press (верстка периодики), CorelDraw (графический редактор), PowerPoint (разработка сценария и стиля презентаций, слайд-фильмы), FaxLine (факсовая связь), Machaon (факсимильная и почтовая связь и безбумажный документообмен), AutoCAD (черчение и конструирование), Adobe Illustrator (дизайнерство), Corel ArtShow (библиотека иллюстраций, созданных художниками всего мира), всемирно известные браузеры Internet Explorer и Netscape Navigator. Кстати, первая версия Netscape Navigator была создана студентами, устроившимися в бесплатный проект для получения первого опыта. Пришли за опытом — а ушли каждый с новым автомобилем «Порше».

Компьютер научился работать с большими массивами данных (базами данных) посредством таких программ, как, например, MS Access (переводится как "доступ"), Oracle и других СУБД (систем управления базами данных). Он дал возможность конструкторам вообще видеть свои творения почти что наяву — на экране монитора. Не построенный еще дом можно было увидеть «живьем» да еще покрутить его во все стороны, чтобы получше рассмотреть, подняться над ним на любую высоту, войти внутрь и посмотреть на вид из окна (системы ArchiCAD , AutoCAD, MicroStation .

Робот-манипулятор, управляемый американской компьютеризированной хирургической системой ZEUS в Бакулевском институте в Москве произвел без непосредственного участия человека две сложнейшие операции — минимально-инвазивную с использованием искусственного кровообращения и коронарного шунтирования на работающем сердце. Человек (хирург), ведущий операцию, сидит за компьютером и на расстоянии управляет действиями чудо машины. Причем, механический монстр управляется голосом (действует программа распознавания голоса). Скоро станет возможным делать сложнейшие операции в глухих уголках любых стран на расстоянии. Людей будут исцелять машины - и все это благодаря компьютеру.

В будущем можно предполагать наличие сотен активных компьютерных устройств, отслеживающих наше состояние и местоположение, легко воспринимающих нашу информацию и управляющих бытовыми приборами.

0,0(0 оценок)
Ответ:
1luvash
29.12.2022 23:41
ответ:  17

// delete.cpp: определяет точку входа для консольного приложения.//
#include "stdafx.h"#include "iostream"#include <conio.h>
using namespace std;
int count_ = 0;
char m[6][6] = { {'S', '.', '.', '.', '#', '#'}, { '#', '.', '#', '.', '.', '.' }, { '.', '.', '#', '.', '.', '#' }, { '.', '.', '#', '#', '#', '.' }, { '#', '.', '.', '.', '#', '#' }, { '#', '#', '#', '.', '.', 'F' }};
int find_p(int x, int y) { if (x < 0 || x > 5 || y < 0 || y > 5) return 0; if (m[y][x] == 'F') return 1; if (m[y][x] != '.' && m[y][x] != 'S') return 0; m[y][x] = '+'; count_++; if (find_p(x, y - 1)) return 1; if (find_p(x + 1, y)) return 1; if (find_p(x, y + 1)) return 1; if (find_p(x - 1, y)) return 1; m[y][x] = 'x'; return 0;}

int main(){ find_p(0, 0); cout << count_; //вывод _getch(); // задержка    return 0;}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота