gfdehk
20.09.2022 07:34

Напишите программу, которая определяет, является ли введенное число четным и больше 100.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
lglglglgl
03.10.2020 18:46
//Скучно
//Pascal ABC.NET 3.1 сборка 1256

Var
 a:integer;
begin
readln(a);
if (a>100) and (not(odd(a))) then writeln('Да') else writeln('Нет');
end.

Пример ввода:
128
Пример вывода:
Да
0,0(0 оценок)
Ответ:
Dk000
03.10.2020 18:46
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var n:=ReadInteger('Введите натуральное число:');
  if n.IsEven and (n>100) then Writeln('Число четное и больше ста')
  else Writeln('Неверно, что число четное и больше ста')
end.

Тестовое решение
Введите нетуральное число: 146
Число четное и больше ста

Введите натуральное число: 38
Неверно, что число четное и больше ста

Введите натуральное число: 101
Неверно, что число четное и больше ста
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота