syltanchik1338
06.06.2021 03:31

Составить программу в паскале, которая определит, поместится ли квадрат со стороной а в круг радиуса r, или круг в квадрат.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
AGENT284
07.09.2020 23:54
Var a, r: real;
begin
write('a = '); read(a);
write('r = '); read(r); 
if r >= a/sqrt(2) then writeln('Квадрат поместится в круг')
else if r <= a/2 then writeln('Круг поместится в квадрат')
else writeln('Круг и квадрат не поместятся друг в друга')
end.

Пояснение:
Радиус описанной около квадрата окружности равен половине диагонали квадрата. Диагональ квадрата по теореме Пифагора = √(a² + a²) = a√2, соответственно радиус = a√2/2 = a/√2. Если радиус данной окружности, больше либо равен a/√2, тогда квадрат помещается в круг.
Радиус вписанной в квадрат окружности равен половине его стороны, т.е a/2. Если радиус данной окружности меньше либо равен, чем a/2, тогда круг вмещается в квадрат.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота