Написать программу в с++ составить программу определения значений указанных ниже линейного массива.выполнить программу для длины массива n=8 сумма обратных величин ненулевых элементов массива
#include <iostream> using namespace std; const int N = 8; //длина массива double s = 0; //начальное значение суммы double mas[N]; //объявляем статический массив длины N int main() { //вводим элементы массива for(int i = 0; i < N; ++i) { cin >> mas[i]; } //пробегаемся по элементам массива for(int i = 0; i < N; ++i) { if(mas[i] != 0.0) //если элемент массива не равен 0 s += 1. / mas[i]; //прибавляем значение обратного элемента к итоговой сумме } cout << s; //вывод суммы на экран return 0; }
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку