aaalino4ka
25.04.2023 09:57

Напишите программу на turbo pascale дана последовательность x1 .. x30,среди положительных элементов найти максимальный и помножить на него все положительные элементы последовательности

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mrgrabik
28.09.2020 12:12
Писал в блокноте, возможны ошибки синтаксиса.

type Mas=array[1..30]of integer;
var i,Value:integer;
begin
for i:=1 to 30 do //заполняем последовательность
readln(Mas[i]);
//ищем максимальное значение
Value:=Mas[1];
for i:=2 to 30 do
if Mas[i]>Value then
Value:=Mas[i];
//умнажаем на максималку все положительные числа
for i:=1 to 30 do
if Mas[i]>0 then
Mas[i]:=Mas[i]*Value;
//вывод значений массива
for i:=1 to 30 do
write(Mas[i]," ");
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота