aidaXD
07.12.2020 05:02

Написать программу, вычисляющую расстояние между точками (x1, y1)и(x2, y2).

язык c#, сделать программу в форме(wfp) программы(то есть фото самой компилируемой программы с кнопками и полями, и также код)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
HelpPlzzzzz
28.01.2021 05:55
Решение с использование длинной арифметики.
var
  i, j, n, len, rem: integer;
  a: array[1..200] of byte;
begin
  write('Введите число: ');
  read(n);
  len := 1;
  a[1] := 1;
  for i := n + 1 to 99 {100} do
  begin
    for j := 1 to len do
    begin
      rem := a[j] * i + rem;
      a[j] := rem mod 10;
      rem := rem div 10;
    end;
    while rem > 0 do
    begin
      inc(len);
      a[len] := rem mod 10;
      rem := rem div 10;
    end;
  end;
  writeln('Произведение чисел из интервала (', n, '; 100): ');
  for i := len downto 1 do write(a[i]);
end.
Пример работы программы:
Введите число: 1
Произведение чисел из интервала (1; 100):
1948348720420644788695888257080283249381963823594360049498643927185579338215778728274424636079639781709574621897447185108592230400000000000000000000
0,0(0 оценок)
Ответ:
Евгений060704
15.04.2022 19:30

Кто с промежуточной аттестацией (тестом) Предупреждение : Wery Hard

--1 во Закончите фразу : "Информация это -

1)Последовательность знаков некоторого алфавита.

2)Книжный фонд библиотеки.

3)Сведения об окружающем мире и протекающих в нём процессах, воспринимаемые человеком непосредственно или с специальных устройств.

4)Сведения,содержащиеся в научных теориях.

--2 во Закончите фразу: "Компьютер это -

1)Устройство для автоматической обработки числовой информации.

2)Устройство для хранения информации.

3)Устройство для поиска,сбора,хранения,преобразования и использования информации в цифровом формате.

4)Совокупность программных средств,осуществляющих управление информационными ресурсами.

--3 во Отметьте информационные процессы (действия с информацией)

1)Работа на компьютере с клавиатурным тренажёром"

2)Установка телефона музыкального диска"

4)Чтение книги"

5)Видеодиск

6)Заучивание правила"

7)Толковый словарь

8)Видео

--4 во Отметьте устройства, предназначенные дл вывода информации.

1)Принтер"

2)Процессор

3)Монитор"

4)Сканер

5)Графопостроитель"

6)Джойстик

7)Клавиатура

8)Мышь

9)Микрофон

10)Акустические колонки"

11)Диск.

--5 во Отметьте элементы окна не имеющие отношения к приложению Paint.

1)Название приложения

2)Строка меню

3)Кнопка Закрыть

4)Кнопка Свернуть

5)Панель инструментов

6)Палитра

7)Панель Формирование"

8)Рабочая область

9)Полосы прокрутки

--6 во Отметьте операции при формировании документов.

1)Вставка

2)Удаление

3)Замена

4)Изменение шрифта"

5)Изменение начертания"

6)Изменение цвета"

7)Поиск и замена

8)Выравнивание"

--7 во Отметьте верное.

1)При формировании текстового документа происходит обработка связанная с получением нового содержания,новой информации или обработка информации не происходит.

2)При разработке плана действий происходит обработка, связанная с изменением формы информации, но не имеющая её содержания"

--8 во Отметьте информационные процессы (действия с информацией).

1)Разговор по телефону"

2)Посадка дерева

3)Диск любимой музыкальной группы

4)Письмо приятелю

5)Выполнение контрольной работы"

6)Разгадывание кроссворда телепередачи"

8)Учебник математики

--9 во пошла дичь) Считая,что каждый символ кодируется одним байтом, определите информационный объём следующего текста :

"В 1642 году Б.Паскаль создал первую механическую счётную машину."

1)64 бита

2)512 БИТ

3)54 байта"

4)512 БАЙТ

--10 во Слово алгоритм происходит от латинской формы написания имени великого математика :

1)Паскаль"

2)Аль Хорезми

3)Аль Фараби.

Всё,большая ответить сегодня,а то завтра мне

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота