stardark03
07.04.2022 08:54

Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0( признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введенные числа по модулю не превышают 30000. программа должна вывести одно число: сумму чётных чисел, больше 5.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
PIPL34linka
27.09.2020 20:46
Var
    a: integer;
    s: longint;

begin
    s := 0;
    readln(a);
    
    while a <> 0 do
    begin
        if (a mod 2 = 0) and (a > 5) then
            s := s + a;
        readln(a);
    end;
    
    writeln(s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота