B1T1S
18.01.2023 18:48

Нужно решение буду завтра итоговая контрольная: дан массив чисел d[i],в котором 7 элементов.найти сумму четных элементов массива,и вычеслить среднее арифметическое всех элементов массива. буду признателен, пишем на паскале, если можно напишите программу, или скиньте скрин! жду

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Собакамаилру
27.09.2020 14:24
Const
n = 7;
var a: array [1..n] of integer; i, m0, m1: integer;
 begin
  m0:=0; m1:=0;
  writeln('Массив -->');
  for i:= 1 to n do readln(a[i]);
   for i:= 1 to n do begin
    m0:=m0+a[i];
    if a[i] mod 2 = 0 then m1:= m1+a[i];
  end;
 writeln('Cумма четных элементов массива: ',m1);
 writeln('Cреднее арифметическое всех элементов массива: ',m0/n);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота