hanter13
25.09.2020 15:44

Нарисуйте блок-схему и напишите программу для исполнителя, которая вычисляет значение функции. выполните 2-мя с неполного условия и вложенного ветвления.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ola124
16.10.2022 07:36

на земле  существует пока что 2 вида информации аналоговая и цифровая. Аналоговая – это та информация которую воспринимаем мы посредством наших сенсоров (видим, нюхаем, трогаем, пробуем на вкус, слышим), цифровая – это информация отраженная в зашифрованном виде. Компьютер работает с цифровой информацией. То есть для того чтобы передать нам рисунок он должен сначала его закодировать в набор чисел, а потом уже раскодировать обратно чтобы вывести на экран монитора. Возьмем к примеру обычные символы. Например когда мы набираем какой-нибудь текст то каждый символ (буква, цифра, знак) имеет свой код. Ведь не надо придумывать несколько сотен тысяч символов для каждого символа каждого языка отдельно. Язык цифр может упростить все. Даже у каждого цвета есть своя цифра, а человеческий глаз может отличит около 16 миллионов цветов. Так что вот почему компьютеры пользуются цифровой информацией. Теперь подробнее о измерения информации. Длину мерят метрами и километрами, вес граммами, килограммами и тоннами, надо же информацию чем то мерить вот и придумали специальные единицы измерения биты, байты, килобайты и т.д. Бит (от английского binary digit - двойной разряд, соответственно 0 и 1) означает самую маленькую единицу измерения.

1 байт - 8 бит

1 КБ (Килобайт) - 1024 Байт

1 МБ (Мегабайт) - 1024 КБ

1 ГБ (Гигабайт) - 1024 МБ

1 ТБ (Терабайт) - 1024 ГБ

Компьютерная система исчисления немного отличается от обычной. В компьютерной системе все исчисления происходят по двоичной системе, т.е. 2-4-8-16-32-64-128-256-512-1024. Вот поэтому ученые и взяли за основу цифру 1024.

Информация единицы измерения количества информации служат для измерения объёма информации — величины, исчисляемой логарифмически. Чаще всего информация единицы измерения количества информации касается объёмакомпьютерной памяти и объёма данных,  передаваемых по цифровым каналам связи. Единица — бит — является основой исчисления информации в цифровой технике. Особое название имеет 4 бита — ниббл (полубайт, тетрада, четыре двоичных разряда), которые вмещают в себя количество информации, содержащейся в одной шестнадцатеричной цифре. Итак, информация о единицах измерения количества информации будет выглядеть следующим образом: байт, килобайт, мегабайт, гигабайт. Понятия информация и единицы измерения количества информации и качество информации тесно связаны между собой. Вопрос выбора информации, единицы измерения количества информации фактически равнозначен выбору основания для логарифма количества состояний. Следует также заметить, что информация, единицы измерения количества информации случайной величины точно равна логарифму количества состояний лишь при равномерном распределении. Во всех прочих случаях количество информации будет меньше.

И конечно система счисления – это записи (изображения) чисел. Различные системы счисления, которые существовали раньше и которые используются в настоящее время, делятся на две группы:

·      Позиционные;

·      Непозиционные.

Наиболее совершенными являются позиционные системы счисления – системы записи чисел, в которых вклад каждой цифры в величину числа зависит от ее положения (позиции) в последовательности цифр, изображающей число.

Наша привычная десятичная система является позиционной.

В числе 34 цифра 3 обозначает количество десятков и «вносит» в величину числа 30: 3×10 + 4 = 34

В числе 304 цифра 3 обозначает количество сотен и «вносит» в величину числа 300: 3×100 + 4 = 304


Позиционные системы счисления – результат длительного исторического развития непозиционных систем счисления.

0,0(0 оценок)
Ответ:
VikiKot1315
25.04.2020 08:45
#include <iostream>
using namespace std;

/*
 * Сумма элементов массива
 * [ 1, 2, 3]  => 6
 * [-5, 8, 2] => 5
 */
int arraySum(int a[], int s)
{
    int ret = 0;
    for (int i = 0; i < s; i++) {
        ret += a[i];
    }
    return ret;
}

/*
 * Определение, каких чисел больше в массиве.
 * [-1,  2,  3]  => "Положительных"
 * [ 1, -2, -3]  => "Отрицательных"
 */
const char* plusMinGreater(int a[], int s)
{
    int plus = 0, minus = 0;
    for (int i = 0; i < s; i++) {
        if (a[i] > 0) plus++;
        if (a[i] < 0) minus++;
    }
    return (plus > minus ?
               "Положительных чисел больше" :
                (plus < minus ?
                    "Отрицательных чисел больше" :
                    "Положителных и отрицательных поровну"));
}

/*
 * Разница между максимальным и минимальным элементами.
 * [5, 3, 2] => 5 - 2 = 3
 */
int maxMinDiff(int a[], int s)
{
    int min = a[0], max = a[0];
    for (int i = 1; i < s; i++) {
        if (a[i] > max) max = a[i];
        if (a[i] < min) min = a[i];
    }
    return max - min;
}

int main()
{
    int n;
    cout << "n = ";
    cin >> n;
    
    int a[n];
    for (int i = 0; i < n; i++) {
        cout << "Число " << i << ": ";
        cin >> a[i];
    }
    
    cout << plusMinGreater(a, n) << endl
         << "Сумма: " << arraySum(a, n) << endl
         << "Разница максимального и минимального элементов: "
            << maxMinDiff(a, n) << endl;
    
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота