melochek228
14.10.2020 05:31

1. Составить программу, по которой компьютер будет запрашивать n целых чисел и выводить на экран только чётные. Сделать 3 варианта программы, используя циклы While, Repeat и For.

2. Составить программу, по которой компьютер найдёт количество нулевых значений.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
милка328
27.06.2021 22:56
1)Excel-когда при копировании и переносе формул в другое место в этих ячейках будет меняться АДРЕС ЯЧЕЕК,подчеркни,относительно нового места.Копировать нужно формулу из ячейки D29 в ячейку F30
2)При перемещении оставшиеся на ней формулы.В ней ссылки не изменяются
3)
Функции категории СТАТИСТИЧЕСКИЕ предназначены в первую очередь для анализа диапазонов ячеек в Excel. С данных функций Вы можете вычислить наибольшее, наименьшее или среднее значение, подсчитать количество ячеек, содержащих заданную информацию, и т.д.
4)Вставка надписей происходит при нажатии Ctrl+V а копирка при Ctrl+C
0,0(0 оценок)
Ответ:
kaleeva1607
12.02.2022 22:11
Program task5; 
  var v:string; ch,p:integer; 
begin 
  writeln('Введите число');
  readln (ch); 
  case ch of 
    1: v:= ('один'); 
    2: v:= ('два'); 
    3: v:= ('три');
    4: v:= ('четыре');
    5: v:= ('пять');
    6: v:= ('шесть');
    7: v:= ('семь');
    8: v:= ('восемь');
    9: v:= ('девять');
    10: v:= ('десять'); 
    11: v:= ('одиннадцать');
    12: v:= ('двенадцать');
    13: v:= ('тринадцать');
    14: v:= ('четырнадцать');
    15: v:= ('пятнадцать');
    16: v:= ('шестнадцать');
    17: v:= ('семнадцать');
    18: v:= ('восемнадцать');
    19: v:= ('девятнадцать');
    20: v:= ('двадцать' );
    21,22,23,24,25,26,27,28,29: begin p:=(ch mod 10); v:= ('двадцать' ); end;
    30: v:= ('тридцать ');
    31,32,33,34,35,36,37,38,39: begin p:=(ch mod 10); v:= ('тридцать' ); end;
    40: v:= ('сорок');
    41,42,43,44,45,46,47,48,49: begin p:=(ch mod 10); v:= ('сорок' ); end;
    50: v:= ('пятьдесят ');
    51,52,53,54,55,56,57,58,59: begin p:=(ch mod 10); v:= ('пятьдесят' ); end;
    60: v:= ('шестьдесят '); 
    61,62,63,64,65,66,67,68,69: begin p:=(ch mod 10); v:= ('шестьдесят' ); end;
    70: v:= ('семьдесят ');
    71,72,73,74,75,76,77,78,79: begin p:=(ch mod 10); v:= ('семьдесят '); end;
    80: v:= ('восемьдесят '); 
    81,82,83,84,85,86,87,88,89: begin p:=(ch mod 10); v:= ('восемьдесят' ); end;
    90: v:= ('девяносто ');
    91,92,93,94,95,96,97,98,99: begin p:=(ch mod 10); v:= ('девяносто ' ); end;
    100: v:=('сто'); 
  end; 
  writeln(v,p); 
end.

Так оно по крайней мере запускается. Но нет обработки переменной p, по ней надо делать отдельный case of.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота