Информатики, написать программу решения следующей : найти целочисленные элементы и номера строк и столбцов, в которых они расположены, для матриц а(5,8); в(6,4). использовать подпрограмму. (язык паскаль)
{Предвещая недовольство: мне самому не нравится эта подпрограмма, но динамические массивы обычно не изучают в школьной программе}
//Pascal ABC.NET v3.1 сборка 1219
Const n1=5; m1=8; n2=6; m2=4;
Type matrixa=array[1..n1,1..m1] of integer; matrixb=array[1..n2,1..m2] of integer;
procedure FindInd(f:integer;maa:matrixa;mab:matrixb); Var i,j:integer; s:string; begin for i:=1 to n1 do for j:=1 to m1 do if maa[i,j]=f then s:=s+'['+inttostr(i)+']['+inttostr(j)+']'+chr(10)+chr(13); writeln('For A:'); writeln(s); s:=''; for i:=1 to n2 do for j:=1 to m2 do if mab[i,j]=f then s:=s+'['+inttostr(i)+']['+inttostr(j)+']'+chr(10)+chr(13); writeln('For B:'); writeln(s); end;
Var maa:matrixa; mab:matrixb; i,j,f:integer; begin randomize; writeln('Matrix A:'); for i:=1 to n1 do begin for j:=1 to m1 do begin maa[i,j]:=random(20); write(maa[i,j]:4); end; writeln; end; writeln('Matrix B:'); for i:=1 to n2 do begin for j:=1 to m2 do begin mab[i,j]:=random(20); write(mab[i,j]:4); end; writeln; end; readln(f); FindInd(f,maa,mab); end.