madecat
02.12.2021 09:07

Составить программу на языке паскаль вводится натуральное число х (х> 9). 1. определить, ли по значению первая и последняя цифры.. например, ввод: 727 вывод: число начинается и заканчивается цифрой 7 ввод 123 вывод первая и последняя цифры не .

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Fara228229
03.10.2020 14:40
Var a,b,c:integer;
begin
write('a = '); readln(a);
b:=a mod 10;
c:=a;
while c>9 do c:=c div 10;
if (a>9) 
 then if b=c
        then writeln('Число начинается и заканчивается цифрой ',c)
        else writeln('Первая и последняя цифры не совпадают')
 else writeln('Число < 10');
end.

Пример:
a = 65478
Первая и последняя цифры не совпадают
0,0(0 оценок)
Ответ:
PSerega11111111
03.10.2020 14:40
Прога в приложении
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота