марго1002
24.09.2022 01:57

Составить программу с++ для определения значений указанных параметров двумерного массива: 1. Определить положение первого чётного элемента массива

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Ionely
01.09.2020 03:45
#include <iostream>
using namespace std;
int main()
{
setlocale(0,"");
int p;
int n;
int kol=0;
cout<<"введите число p которое проверяется";
cin>>p;
cout<<"введите число n первых нечётных чисел ";
cin>>n;
for (int i=1;i<=n*2;i++)
  {
  for (int j=1;j<=n*2;j++)
    {
    if ( ((i%2)==1) && ((j%2)==1) ) n2++;
    if ( ((i%2)==1) && ((j%2)==1) && ((i*j)==p) ) kol++; 
    }
  }
cout<<"количество "<<n<<" первых нечётных чисел кратных "<<p<<" = "<<kol;
return 0;
}
0,0(0 оценок)
Ответ:
Aminka555112
17.11.2021 06:30
#include <iostream>
#include <vector>
#include <cstdlib>
using namespace std;

int main()
{
int count;
cout <<"Введите размер массива: ";
cin >>count;
vector<int> v(count);
srand(time(0));
for (int i=0; i<count; i++)
{
v[i]=rand()%100;
cout <<v[i] <<" ";
}
cout <<endl;
int c=0;
int n;
cout <<"Введите максимальный элемент: ";
cin >>n;
for (int i=0; i<v.size(); i++)
if (v[i]>n)
{
v[i]=n;
c++;
}
cout <<"Было произведено " <<c <<" замен" <<endl;
for (int i=0; i<v.size(); i++)
cout <<v[i] <<" ";
cout <<endl;

return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота