6yterffjdjd
11.08.2022 17:44

Составьте программу удаления элементов одномерного массива a(n), больших заданного числа k в паскале abc

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
liza0234
07.09.2020 20:50
Не совсем понятно условие, но вот возможное решение в C++
#include <iostream>
#include <iomanip>
#include <ctime>
int main()
{
    using namespace std;

    cout << "Enter N: ";
    int N;
    cin >> N;

    int * A = new int[N];
    srand(time(0));
    for (int i = 0; i < N; ++i)
        A[i] = rand() % N + 1;

    for (int i = 0; i < N; ++i)
        cout << setw(4) << A[i];

    cout << "\nEnter K: ";
    int K;
    cin >> K;

    int SIZE = 0;
    for (int i = 0; i < N; ++i)
        if (A[i] <= K)
            ++SIZE;

    if (SIZE > 0)
    {
        int * A1 = new int[SIZE];
        int i1 = 0;
        for (int i = 0; i < N; ++i)
            if (A[i] <= K)
            {
                A1[i1] = A[i];
                ++i1;
            }
        for (int i1 = 0; i1 < SIZE; ++i1)
            cout << setw(4) << A1[i1];
        delete[] A1;
    }
    else
        cout << "No elements" << endl;
    delete[] A;
    cout << endl;
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота