annareain252
03.09.2021 12:27

Напишите программу, которая заполняет массив размерностью 40 следующими данными: элемент №1-№5 - целыми числа, введенные пользователем элемент №6-№10 - случайными целыми числами (из диапазона от 0 до 10) элемент №11-№15 - случайными целыми числами (из диапазона от -10 до 0) элемент №16-№20 - случайными целыми числами (из диапазона от 20 до 50) элемент №21-№25 - случайные целые числа (из диапазона от -50 до -20) элемент №21-№25 - правило заполнения: каждый элемент массива равен сумме двух следующих. элемент №31-№40 - правило заполнения: каждый элемент массива равен квадрату своего индекса. весь массив выводится на экран в одну строку. текст программы прислать в ответ на данное

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ната34567890
30.08.2020 22:55
В одном месте, видимо, опечатка (№ 21-25 два раза, а № 26-30 нет).
const n=40;
var x:array[1..100] of real;
i:integer; 
begin
Randomize;
for i:=1 to 5 do begin
 write('x[',i,']=');
 readln(x[i]);
 end;
for i:=6 to 10 do x[i]:=random(11);
for i:=11 to 15 do x[i]:=random(11)-10;
for i:=16 to 20 do x[i]:=random(31)+20;
for i:=21 to 25 do x[i]:=random(31)-50;
for i:=31 to 40 do x[i]:=i*i;
for i:=30 downto 26 do x[i]:=x[i+1]+x[i+2];
for i:=1 to n do write(x[i],' ');
writeln;
end.

Пример:
x[1]=32
x[2]=49
x[3]=81
x[4]=27
x[5]=50
32 49 81 27 50 3 7 7 6 5 -9 -4 -3 -3 0 23 32 40 24 36 -43 -26 -34 -44 -22 12808 7877 4931 2946 1985 961 1024 1089 1156 1225 1296 1369 1444 1521 1600 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота