rotsib
06.05.2020 04:50

Написать программу (в pascal) и составить блок-схему по : в двумерном массиве произвольной размеренности подсчитать количество элементов, равных наибольшему элементу в этом массиве. вывести значение наибольшего элемента.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ruslanmorozko
26.06.2020 21:02
Алгоритм
Ввод массива A[n,m]
Max := A[1,1]; k := 1; p := 1; s := 0;
Алгоритм
Ввод массива A[n,m]
Max := A[1,1]; k := 1; p := 1; c := 0;
Цикл по i от 1 до n (по строкам)
Цикл по j от 1 до m (по столбцам)
Если (A(i, j) = Max) and ((i<>k) or (j<>p)) То c := c+1;
Если (A(i, j) > Max) То
k := i; p := j; c := 1;
Max: = A(i, j);
Конец Если
Конец цикла по столбцам
Конец цикла по строкам
Вывод "Элемент ", Max, " встречается ", c, " раз"
Конец.

Программа
var A: array of array of integer
var i,j,m,n,k,p,s,Max: integer
BEGIN
uses crt; clrscr;
write ('Vvedite kol-vo strok: '); readln (n);
write ('Vvedite kol-vo stolbtsov: '); readln (m);
setlength(A,n,m);
for i=1 to n do
begin
for j=1 to m do
begin
write ('Vvedite element vassiva: '); readln (A[i,j]);
end;
end;
Max := A[1,1]; k := 1; p := 1; c := 0;
for i=1 to n do
begin
for j=1 to m do
begin
if (A(i, j) = Max) and ((i<>k) or (j<>p)) then c := c+1;
if (A(i, j) > Max) then
begin
k := i; p := j; c := 1;
Max: = A(i, j);
end;
end;
end;
write ('Element ', Max, ' vstrechaetsya ', c, ' raz');
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота