yuliyabondar2
23.10.2022 13:53

Напишите программу, которая вводит с клавиатуры 20 реальных чисел, и организовывает их хранение в массиве. после этого определяет сумму элементов, значение которых больше среднего арифметического элементов массива.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
pelmenev777
24.09.2020 11:17
Const n=20;
var x:array[1..n] of real;
i:integer; s,sr:real;
begin
for i:=1 to n do
 begin
 write('x[',i,']=');
 readln(x[i]);
 end;
s:=0;
for i:=1 to n do s:=s+x[i];
sr:=s/n;
s:=0;
for i:=1 to n do
 if x[i]<sr then s:=s+x[i];
writeln('sr = ',sr,'  s = ',s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота