Нина20071
23.11.2020 05:53

Решить на Python

Определите количество различных выплаты сдачи в размере n рублей купюрами 10 рублей и монетами 5, 2 и 1 рубль.

Например, 5 рублей можно выплатить четырьмя различными Входные данные
На вход программе подается натуральное число n1000 — размер сдачи, которую необходимо выплатить.

Выходные данные
Выведите искомое количество выплаты.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Неизвестный17781
20.03.2021 08:05

#include <iostream>

using namespace std;

int main()

{

int n, x = 0, count = 0;

cin >> n;

int arr[n];

for (int i = 0; i < n; i++)

{

cin >> arr[i];

for (int i = 0; i < n; i++)

{

if (arr[i] > 0 && x == 0)

{

cout << i; //положительный

x = 1

}

if (arr[i] < 0) count++;

}

cout << endl << count;

return 0;

}

Объяснение:

Введите сначало количество елементов массива, а потом сами елементы через пробел

Выведет номер первого положительного и количество отрицательных.

0,0(0 оценок)
Ответ:
andrognew2018
27.01.2021 02:26
{Лови прогу для одномерного массива. Если он двумерный, могу модифицировать.
Должна работать, не работает - отпишись, отыщу паскаль и исправлю.
Кидай прям весь ответ, кэп. Комментарии подотри, опять же кэп}

program massiv;
var x:array[1..10] of real;
n, i:integer;
s:real;

begin
writeln('Vvedite razmer massiva');
readln(n);
if (n<1) or (n>10) then writeln('Neverno zadano znacheniye razmera massiva')
else begin {check: +}
for i:=1 to n do begin writeln('Vvedite element ', i, 'iz ', n); readln(x[i]); end; {enter the array}
s:=0;
for i:=1 to n do
begin
s:=s+power(x[i], 3);
end;
writeln(s:2:2);
end;
readln; {stop here to read the program answer}
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота