Войти
Регистрация
Спроси ai-bota
alena250880
31.07.2021 14:25
Написать программу на языке c++. перевести с рекурсивной функции conv (n, p) за- данное натуральное число n в p-ичную систему счисления (2 ≤ р ≤ 9).
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
ЦУКПРОЛ
02.10.2020 01:47
Выполните сложения чисел а)11101010102+101110012...
Victoria0NK
02.10.2020 01:47
Сколько бит в пословице - сделал дело- гуляй смело...
ilyadmitriev0
02.10.2020 01:47
Переведите числа в десятичную систему счисления. а) 1110001112; б) 1000110112; в) 1001100101,10012; г) 1001001,0112;...
sapeglub
02.10.2020 01:47
Asus материнская плата n13219 d33005 характеристики...
Юлиан228
14.12.2020 12:29
Втаблице запросы и количество страниц, которые нашел поисковый сервер по этим запросам в некотором сегменте интернета: торты| пироги 12000торты & пироги 6500 пироги...
Дайяник
14.12.2020 12:29
Выражение а+а(вектор) p.s. над двумя буквами а расположена длинная черта как общий вектор...
Amaliya211013
14.12.2020 12:29
12. учащимся 8 класса необходимо написать программу для младших школьников для проверки знаний таблицы умножения. выберите подходящее программное обеспечение: a) delphi,...
qwertyyuill
25.04.2023 13:53
1. Дан фрагмент электронной таблицы. В ячейку D1 введена формула =$В$1*3+C2/2. Укажите элемент формулы, который содержит относительную ссылку.2. Дан фрагмент электронной...
ansher76
10.02.2020 00:25
Высказывание, никакая часть которого сама не является высказыванием...
Vladislava256
03.04.2023 19:38
Составить программу вычисления следующих функций:...
Ответ:
Vee19
03.10.2020 11:59
#include <iostream>
using namespace std;
void conv(int n, int p) {
if(n/p!=0){
conv(n/p,p);
}
cout << n%p;
}
int main()
{
int n, p;
string m;
cout << "Введите n:", cin >> n, cout << "\n";
cout << "Введите p:", cin >> p, cout << "\n";
conv(n,p);
return 0;
}
Пример:
Введите n: 511
Введите p: 8
777
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота