Войти
Регистрация
Спроси ai-bota
Vladislava256
03.04.2023 19:38
Составить программу вычисления следующих функций:
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
жпжрдмдопнулуу
01.05.2023 15:57
Компьютер определяется IP адресом 192.168.5.200 укажите номер компьютера в сети...
yuliya19999
18.10.2021 07:07
Документ з 4 сторінок має два розділи. Якою може бути нумерація сторінок? 1). 3,4,6,7 2). ІІІ, V, 1,2 3). А, Б, В, Г 4). 7, 9, 3,5 5). 2,5,4,3 6). 6,3,4,5...
skyblue1
24.01.2022 22:58
Замінити нулем від ємні елементи масиву дійсних чисел...
tylerxjosh
24.01.2022 22:58
Знайти найбі та найменший елемент масиву дійсних чисел....
BigD13
30.11.2020 15:34
Как называется наука о законах и формах мышлениях ...
001Карина11111
20.11.2021 04:49
ОЧЕНЬ составить таблицу истинности Если можно, то решите на листике Заранее просто огромное вам...
omararu2006
30.03.2021 10:05
Описать методику выделения областей на изображениях...
olya363
02.05.2021 07:46
НАДО РЕШИТЬ ЗАДАЧУ ДВОМЯ ФУНКЦИИ 1) ПАРАМЕТРМИ УКАЗАТЕЛЯМИ 2) ПАРАМЕТРМИ ССЫЛКАМИ . Найти размеры всех треугольников, площадь которых равна заданному натуральному числу и стороны...
Rima02
09.02.2023 23:04
К какому программному обеспечению относится расшифровка записей...
Disna2006
15.08.2020 07:37
К какому программному обеспечению относится расшифровка записей ...
Ответ:
anastasiyabalk1
16.09.2022 20:21
//PascalABC.NET (версия 3.1, сборка 1196 от 09.03.2016)
begin
for var i:=1 to 1000 do
if i mod 7 =0 then print(i);
end.
Тестовое решение:
7 14 21 28 35 42 49 56 63 70 77 84 91 98 105 112 119 126 133 140 147 154 161 168 175 182 189 196 203 210 217 224 231 238 245 252 259 266 273 280 287 294 301 308 315 322 329 336 343 350 357 364 371 378 385 392 399 406 413 420 427 434 441 448 455 462 469 476 483 490 497 504 511 518 525 532 539 546 553 560 567 574 581 588 595 602 609 616 623 630 637 644 651 658 665 672 679 686 693 700 707 714 721 728 735 742 749 756 763 770 777 784 791 798 805 812 819 826 833 840 847 854 861 868 875 882 889 896 903 910 917 924 931 938 945 952 959 966 973 980 987 994
0,0
(0 оценок)
Ответ:
vlada363
16.03.2020 21:38
Думаю нет большой разницы между процедурой и функцией, просто функция куда удобнее.
Для нахождения нода используется алгоритм Эвклида
//PascalABC.Net
function NOD(A, B: integer): integer;
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
procedure pNOD(A, B: integer; var NOD: integer);
begin
while A <> B do
if A > B then A := A - B else B := B - A;
NOD := A;
end;
begin
var a: Array of integer := (16, 32, 40, 64, 80, 128);
var n := a[low(a)];
for var i := low(a) to high(a) do
pNOD(n, a[i], n);
Writeln(n);
end.
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота