TimuR2112
02.03.2023 23:07

)нужно сформулировать условие , которое решается в данной программе: program uses crt; var n: integer; s: byte; begin write('введите натуральное число: '); readln(n); s: =0 while n < > 0 do begin s: = s + n mod 10; n: =n div 10 end; writeln('s=',s: 4); end.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
333399
03.10.2020 10:40
1. Ошибка в коде: после S:=0 нет " ; "
2. Формулировка может быть такой:
Напишите программу, которая для натурального числа N получает сумму его цифр.
Программа на вход получает одно число N - натуральное. На выходе получаем одно число S - сумма цифр числа N.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота