Вика7473
06.04.2020 08:36

Составить программу которая находит количество двузначных чисел фибоначчи которые начиная с заданного номера n при делении на 5 в остатке заданное z

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Женя111сивар
23.09.2020 10:59
Var a,b,c,n,n2,z:integer;
begin
 write('введите номер первого числа n ==> ');
 readln(n);
 write('введите искомый остаток ==> z ');
 readln(z);
 b:=0;
 n2:=0; 
a:=1;
  while c<100 do begin
    c:=a+b; 
    b:=a;
    a:=c;
    n2:=n2+1;
    if (n2>=n) and (c mod 5 = z) then writeln('нужное число ==> ',c);    
  end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота