hsjsjxn
23.11.2020 14:21

Напишите программу в паскаль, которая получает день и номер месяца, а выводит количество дней, оставшихся до нового года. считайте, что год невисокосный (365 дней). учтите, что слово "дней" может иметь также формы "день" и "дня". пример: введите день и месяц: 25 12 осталось 7 дней до нового года. пример: введите день и месяц: 1 1 осталось 364 дня до нового года. пример: введите день и месяц: 31 2 неверная дата.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
elyaminaewap06uze
03.10.2020 08:43
//PascalABC
Uses System;
var day, month: integer;
begin
  Read(day, month);    var d := new DateTime(DateTime.Now.Year, month, day);    var new_year := new DateTime(d.Year+1, 1, 1);    Writeln((new_year - d).TotalDays);  end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота