Gerty21
20.10.2021 01:12

Составить программу паскаль для нахождения площади трапеции с основаниями а ,б меньшн h

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Макс11171
07.08.2020 10:21
{ s(трапеции) = ((a+b)/2)*h; }
uses crt;
var
a, b, h: Integer; (Real)
s: Real;
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end.
Если же а и б должны быть обязательно меньше h, то:
if (a < h) and (b < h) then
begin
WriteLn('Введите а: ',a);ReadLn(a);
WriteLn('Введите b: ',b);ReadLn(b);
WriteLn('Введите h: ',h);ReadLn(h);
s:= ((a+b)/2)*h;
WriteLn('S = ', s);
ReadLn;
end;
else begin
WriteLn('Основания не меньше h!');
ReadLn;
end;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота