Написать программу, которая, решает квадратное уравнение |ax+b|=cx+d. на вход вы получаете a,b,c,d. на выходе должно быть, либо 2 корня если таких 2, либо 1, либо надпись что корней нет
Program rtr1;Uses crt;Var a,b,c,d,di,f,x1,x2:real;Begin Clrscr; Readln(a,b,c,d); f:=0; di:=sqr(2*a*b-2*c*d)-4*(a*a-c*c)*(b*b-d*d); if di>0 then begin x1:=((2*c*d-2*a*b)+sqrt(di))/(2*a*a-2*c*c); x2:=((2*c*d-2*a*b)-sqrt(di))/(2*a*a-2*c*c); if (abs(a*x1+b)=c*x1+d) then f:=f+1; if (abs(a*x2+b)=c*x2+d) then f:=f+1; end else if d=0 then begin x1:=(2*c*d-2*a*b)/(2*a); if (abs(a*x1+b)=c*x1+d)then f:=f+1; end else writeln('Корней нет'); Writeln('Уравнение имеет ',f,' корней ');End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку