polinasmi1
02.10.2021 07:40

Написать программу нахождения суммы нечётных цифр в натуральном числе. pascal

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
9fhneh
03.10.2020 07:34
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
  var n:=ReadInteger('n=');
  var s:=0;
  while n<>0 do begin
    var d:=n mod 10;
    if Odd(d) then s+=d;
    n:=n div 10
    end;
  Writeln('Сумма нечетных равна ',s)
end.

Тестовое решение:
n= 25325423
Сумма нечетных равна 16
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота