arinasuper000
28.03.2020 23:45

Составить программу, которая определяет, есть ли среди цифр целого трёхзначного числа одинаковые

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dima140916
13.08.2020 19:30
// PascalABC.NET 3.1, сборка 1171 от 15.02.2016
begin
  var s:=ReadInteger('n=').ToString;
  if (Pos(s[1],Copy(s,2,2))>0) or (s[2]=s[3])
  then Writeln('Есть одинаковые цифры')
  else Writeln('Нет одинаковых цифр')
end.

Тестовое решение:
n= 141
Есть одинаковые цифры
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота