dashaananasic18
15.07.2022 20:10

Написание программы на языке c++, написать программу. : составьте программу которая вводит символы до знака $. пусть программа считает число введённых точек и выведет подсчитанное количество на экран монитора. . написано было в визуал студио 2015

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
raisabarsegyan
27.05.2020 16:32

Привет, я тестировал на VS 2017, но разницы нет, я тебя уверяю (по крайней мере в данном случае).

Кратко об моём решении. Запускаю цикл и считываю символ в переменную, если это точка, добавляю к счётчику +1, если доллар - цикл прекращается.

Мой вариант решения:

#include <iostream>

using namespace std;

int main()

{

char symbol;

int counter = 0;

do

{

 cout << "Enter symbol -> ";

 cin >> symbol;

 if (symbol == '.') counter++;

} while (symbol != '$');

cout << "Dot's counter " << counter << endl;

cin.get();

cin.get();

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота