olgateviasheva
04.04.2020 08:56

Составьте программу в паскаль. в кафе лимонад по n руб. и мороженое по t руб. составьте алгоритм, который сообщает "возьмите сдачу", "доплатите еще" или " за покупку" при оплате покупателем за m лимонадов и r мороженых денег в размере s руб.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ghhhghf
21.09.2020 10:17
Var n,t,m,r,s,raznica:real;
begin
    writeln('Цена лимонада?');
    readln(n);
    writeln('Цена мороженого?');
    readln(t);
    writeln('Сколько покупаете лимонада?');
    readln(m);
    writeln('Сколько покупаете мороженого?');
    readln(r);
    writeln('Сколько даёте денег?');
    readln(s);
    raznica:=s-(n*m+t*r);
за покупку!') else if raznica>0 then writeln('Возьмите сдачу: ', raznica, ' рублей') else writeln('Доплатите ещё ', abs(raznica), ' рублей');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота