Anastasiya12377
20.01.2020 21:04

написать программу в паскале: надо заполнить массив случайными числами в диапазоне от 25 до 50, найти сумму четных чисел и их количество.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
c1Darkness1c
10.08.2020 08:52
// PascalABC.NET 3.2, сборка 1457 от 29.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),25,50); a.Println;
  var s:=a.Where(x->x.IsEven);
  Writeln('Четных чисел- ',s.Count,', их сумма равна ',s.Sum)
end.

Пример
n= 17
47 35 50 48 27 49 34 41 44 25 37 31 35 31 41 50 32
Четных чисел- 6, их сумма равна 258
0,0(0 оценок)
Ответ:
RADIUM24
10.08.2020 08:52
Begin
  var a := arrrandom(readinteger('Введите размер массива:'), 25, 50).println;
  writeln('Кол-во четных чисел:', a.where(x -> x mod 2 = 0).count);
  writeln('Сумма четных чисел:', a.where(x -> x mod 2 = 0).sum);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота