aikena2005
14.09.2021 09:28

Дан целочисленный массив из 20 элементов. элементы массива могут быть целыми числами от -1000 до 1000. найдите минимальный элемент среди положительных, делящихся на 3 и нечетных

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
mobidik77
20.09.2020 16:02
Uses crt;
const n=20;
var i,min:integer;
a:array [1..n]   of integer;
begin
randomize;
for i:=1 to n do
 a[i]:= random(2001)-1000; {read (a[i])}{ручной ввод чисел}
min:=1001;
for i:=1 to n   do
if (a[i]>0)  and (a[i]mod 3=0) and (odd(a[i])) and (a[i]<min) then
 min:=a[i];
if min<>1001 then
 writeln(min)
else
  writeln('нет чисел удовлетворяющих заданному условию');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота