Войти
Регистрация
Спроси ai-bota
ariana201723
24.03.2022 15:07
C++ в массив a длиной n из всех одинаковых элементов оставьте только по одному представителю. остальные удалите. рассмотрите 2 варианта: а) массив б) не
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
karina200612
09.11.2022 14:51
нужно! Пycть имeeтcя пocлeдoвaтeльнocть пpoизвoльныx цeлыx нeнyлeвыx чиceл, зaвepшaющaяcя чиcлoм 0 (чиcлo 0 в пocлeдoвaтeльнocть нe вxoдит). Кoличecтвo элeмeнтoв в пocлeдoвaтeльнocти...
tab3190717
07.02.2021 13:02
Создать многослойный документ: (файл Рс.jpg), разместить на мониторе цветок (файл Viola.jpg), на котором сидит бабочка (файл Butterfly.jpg), а на клавиатуре расположить веточку...
moskvina08
07.05.2020 23:44
Знаю что вам в падлу делать но ...
елена1229
26.05.2023 05:23
Задача грибы даю. Условие на картинке и обстановка тоже....
kivlad96
15.07.2021 17:55
Укажи минимальный объём памяти (в битах), достаточный для хранения любого растрового изображения размером 61×61 пикселя, если известно, что в изображении используется палитра...
Plushkina69
05.09.2022 03:23
Укажи минимальный объём памяти (в битах), достаточный для хранения любого растрового изображения размером 40×40 пикселя, если известно, что в изображении используется палитра...
Dhshssh
01.10.2022 04:24
Составить программу в паскале. даны стороны треугольника а,в,с.найти его периметр....
kotovaalina31
07.04.2020 23:11
Можно ли управлять исролнителем без обратной связи(например,роботом)?В чём недостаток такого метода...
maistrenko1
25.08.2020 14:56
Дано три дійсних числа a, b, c. Якщо a b c то всі числа збільшуються у двічі, інакше зменшуються на одиницю. python. Нужен код...
Illya227
27.12.2020 01:48
ответьте на во ответьте отдельно для каждой модели):1. Какие виды передач используются в модели (зубчатая, коронная, червячная)2. Когда начнет работать модель и когда остановится?3....
Ответ:
зарина67489
31.07.2020 13:21
//массив отсортировать, удалить повторные
#include <iostream>
#include <list>
#include <cstdlib>
#include <ctime>
#include <iomanip>
using namespace std;
int main() {
int j,n;
list<int> lst;
list<int>::iterator it1;
// начальная установка генератора случ. чисел
srand(time(NULL));
//заполнение списка
cout<<"n = "; cin>>n;
for (j=0; j<n; j++)
lst.push_back(rand() % 10);
//вывод на экран
cout<<"initial array: ";
for (it1=lst.begin(); it1!=lst.end(); it1++)
cout<<*it1<<" ";
//сортировка, удаление повторных
lst.sort();
lst.unique();
//вывод списка
cout<<endl<<"after removing: ";
for (it1=lst.begin(); it1!=lst.end(); it1++)
cout<<*it1<<" ";
cout<<endl;
system("pause");
return 0;
}
В варианте без сортировки (что, вообще говоря, не принципиально) убираете строку lst.sort();
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота