8639
18.05.2020 10:27

Написать программу на паскале : ) составить программу, проверяющую, являются ли данные три числа взаимно простыми. использовать подпрограмму.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
MasterSporta13
03.10.2020 03:09
Числа являются взаимно простыми, если их наибольший общий делитель равен 1. Используя это свойство, напишем программу:
var
  a, b, c: integer;

{НОД двух чисед}
function gcd(a, b: integer): integer;
var t: integer;
begin
  while b > 0 do
  begin
    t := b;
    b := a mod b;
    a := t;
  end;
  gcd := a;
end;

{Проверка трех чисел на взаимную простоту}
function isCoprime(a, b, c: integer): boolean;
begin
  isCoprime := gcd(gcd(a, b), c) = 1;
end;

begin
  read(a, b, c);
  if isCoprime(a, b, c) then write('Числа взаимно простые')
                        else write('Числа не являются взаимно простыми');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота