alekslisalove
28.12.2021 22:18

Сосновами java!

напишите программу где я ввожу логин и пароль. и если они , то мы выводим authentication completed, иначе invalid login or password.

(логин должен быть user, пароль - qwerty)

сравнение строк вы делаете с метода

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Møŝķá56
17.09.2020 19:23

import java.util.Scanner;

public class Authenticator {

public static void main(String[] args) {

 String login;

 String password;

 Scanner scan = new Scanner(System.in);

 

 System.out.println("login:");

 login = scan.next();

 System.out.println("password:");

 password = scan.next();

 

 if(login.equals("user") && password.equals("qwerty")){

  System.out.println("Authentication completed");

 }else{

  System.out.println("Invalid login or password");

 }

 

 scan.close();

 

}

}

Объяснение:

Краткий алгоритм этой программы:Импортируем класс Scanner(для ввода текста);В методе main создаем две переменные типа String и одну типа Scanner;Вводим значения при а;Если логин и пароль верны,то выводим Authentication completed. Иначе выводим Invalid login or password;Закрываем Scanner;
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота