FreeSasha
09.05.2020 03:14

Написать программу, которая 30 раз выводит в переменную, а случайные числа, и суммирует те из них, которые больше, чем 40. диапазон чисел до 55

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
fox359
26.05.2020 16:45

Program mmm;

Var a : real;  

var i: integer;  

s: real;

begin

s:=0;

Randomize;

For i := 1 To 30 Do

Begin

   a := random*100-45;

   writeln(a:6:2) ; //выписываем сгенерированные числа, необязательно

if   a>40 then

 s:=s+a;

 End;

writeln(s:6:2) ;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота