Арина20071278383
05.07.2020 01:47

На оператора выбора. составить программу к : для целого числа k от 1 до 99 напечатать фразу "мне k лет",учитывая что может быть "лет","год" ,"года"

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
NerminJaleÇiçek
26.05.2020 12:55

uses crt;
var r: byte;
begin
readln(к);
write('Мне ',к);
if r in [5..20] then write(' лет') else
  case к mod 10 of
1: write(' год');
2..4: write(' года');
5..9,0: write(' лет');
else

writeln('error');
end;
end.

через case оч хорошо всё получается)

 

или вот так по подробнее:

 Const st='Мне';
Var
k: Byte;
BEGIN
Repeat
Write('Введите K (от 1 до 99): ');
Readln(k);
until k in [1..99];
Case k of
11..20: Writeln(st,' ',k,' лет');
Else
begin
Case k mod 10 of
1: Writeln(st,' ',k,' год');
2..4: Writeln(st,' ',k,' года');
5..9,0: Writeln(st,' ',k,' лет');
end;
end;
end;
Readln
END.

 

 

 

 

 

 

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота