2006zahar2006
10.04.2021 05:34

Взаданном массиве вычислить среднее арифметическое значение элемента массива. зарание составить программу )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
wikwik
05.10.2020 06:52
Const n=10; 
var a:array[1..n] of integer;
i,s:integer; 
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
 begin
 a[i]:=random(51)-25;
 write(a[i]:4);
 end;
writeln;
s:=0;
for i:=1 to n do s:=s+a[i];
writeln('среднее арифметическое элементов массива = ',s/n);
end.

Пример:
Массив A:
   4 -25  -8  17   1  15 -23 -13  16 -22
среднее арифметическое элементов массива = -3.8
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота