danik24rysskiy
20.01.2020 01:45

Вам дан массив из n целых чисел. вы должны найти в этом массиве минимум и максимум, после чего подсчитать их усреднённое значение. формат входных данных в первой строке входных данных находится одно натуральное число n (n≤105) — количество элементов в массиве. во второй строке находятся n целых чисел, не превышающих по модулю 109 — элементы массива. формат выходных данных требуется вывести усредненное значение минимума и максимума. примеры входные данные 5 7 2 1 8 5 выходные данные 4.5

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
rushsh1
26.05.2020 09:45

И что тут сложного?

#include <iostream>

using namespace std;

int main()

{

   int n;

   

   cin >> n;

   

   int32_t arr[n];

   

   for (size_t i = 0; i < n; ++i)

   {

       cin >> arr[i];

   }

   

   int32_t max = arr[0], min = arr[0];

 

   for (auto &i : arr)

   {

       if (i > max) max = i;

       if (i < min) min = i;

   }

   

   cout << static_cast<float>(max + min) / 2 << "\n";

   

   return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота