NikolayMakaren
08.01.2023 02:12

Даны два действительных числа составьте программу которая меньшее из них занимает их полусуммой а большее произведением.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
petrovasofia0
06.10.2020 01:35
#include <iostream>

int main() {
 double a, b, t;
 std::cin >> a >> b;
 if( a > b) {
    t = a;
    a = a * b;
    b = (t + b) / 2;
  } else {
    t = a;
    a = (a + b) / 2;
    b = t * b;
  }
  std::cout << a << " " << b << std::endl;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота