glokol
25.06.2020 06:59

С. написать программу для : пользователь вводит с клавиатуры величину, выраженную в килобайтах. программа переводит ее в биты и мегабайты. в паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Shermetovelyar552
26.05.2020 07:36

var x: real;

begin

writeln('Введите число(Кб): ');

readln(x);

writeln(x,' Кб = ',x*1024*8,' бит');

writeln(x,' Кб = ',x*1024,' байт');

writeln(x,' Кб = ',x/1024,' Мб');

end.

0,0(0 оценок)
Ответ:
Reson1
26.05.2020 07:36

program line_4;

uses crt;

var

kb, b: longint;

mb: real;

begin

clrscr;

write(‘kb (килобайт) = ‘); readln(kb);

b:=kb*1024*8;

mb:=kb/1024;

writeln(kb,‘ килобайт = ‘, b, ‘ бит = ‘, mb:6:4, ‘ мб’);

readkey;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота