Darkparadise02
19.03.2023 14:40

Решите в тетради , используя цикл while-wend 1. написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kaskader2475
30.09.2020 19:14

begin

read(n);

while (n <> 0) do // пока не равно нулю делать

 begin

 s := s + n;

 k = k + 1;

 end.

writeln(s/k); // среднее

writeln(s); // сумма

end.

Переменные сам объяви. s и к должны быть типа real

Если что-то не понятно пиши в ЛС

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота