anystti
25.03.2023 07:05

Напишите программу поиска минимального и максимального элементов матрицы. программа должна менять максимальный и минимальный элементы между собой и выводить на экран исходную и преобразованную матрицы (турбо паскаль)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
uhsdjhsilhiilch
24.07.2020 12:30
 Program al;
  var  a: array[1..32000] of integer; 
 buf:integer; 
 i,n,min,max:integer;
begin 
  writeln('n='); 
readln(n); 
 writeln('vvedite massiv=');
  for i := 1 to n do 
 readln(a[i]); 
min:=1;
  max:=1; 
 for i:=2 to n do 
   begin   
   if a[min]>a[i] then   
     min:=i; 
    if a[max]<a[i] then 
      max:=i;   
 end; 
buf:=a[min];
  a[min]:=a[max]; 
a[max]:=buf; 
writeln('Massiv posle obmena max<->min'); 
 for i:=1 to n do 
  write(a[i]:4); 
writeln; 
 end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота