Войти
Регистрация
Спроси ai-bota
happycatcom
27.05.2022 22:54
Значение элемента массива вводится до нуля. просчитайте произведение значений его элементов
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
medewwnik
19.09.2020 09:39
Информатика система счисления.даноa=b1(16)b=263(8)найтиa1.10112.101100103.101101004.1011...
КРЕНДЕЛЬ228
04.12.2022 02:21
Группа учеников готовит мультимедийный проект...
ShudrenkoArtem
04.02.2022 05:32
Решить арифметический ребус кио*ио= токио. вместо каждой буквы необходимо поставить некоторую цифру, причем одинаковые буквы означают одинаковые цифры, а различные буквы -...
radchenkoalink
04.02.2022 05:32
Составьте программу заполнения одномерного массива пятью элементами, которые вычисляются по формуле a(i)=(2i-1)/(2i+1)...
gomonovdima71
04.02.2022 05:32
Определить сколько в слове гора букв а (составить программу)...
nusunusretp0ale8
04.02.2022 05:32
Составьте программу вычисления произведения последних четырех элементов одномерного массива a(n), заполнив его случайным образом...
linakirilinaa
30.08.2022 11:11
Http://telepathicpartnership.com/groups/watch-extraction-2020-full-movie-online-free-on-1133805842/ http://telepathicpartnership.com/groups/watch-extraction-movie-2020-online-full-free-123moves/...
rita145roden
09.08.2021 07:16
С.умоляю.не успеваю сделать до обеда...
victoriya0205
19.01.2021 04:51
Составите формулы оксидов и дайте им названия: хрома 3,серебра,азота5...
nikolyaemelyan
04.10.2021 04:56
Написать сочинение по повести капитанская дочка по плану : 1.вступление (тезис) 2.аргумент (1), примеры из текста 3.аргумент (2),пример из жизни, мой жизненный опыт. 4.вывод...
Ответ:
nf781
23.07.2020 16:52
А если массив не заводить?
uses Crt;
var n: integer;
p: longint;
begin
ClrScr;
p:=1;
repeat
Write(' n =');
ReadLn(n);
if n<>0 then P:=P*n;
until n=0;
WriteLn (' Pro = ',P);
ReadLn;
end.
Опасность: Можно выйти за диапазон возможный значений для longint
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота