mira23141
01.02.2022 06:07

Напишите программу, которая показывает количество нечетных чисел в числе. ( если можно, то без программы while и не слишком мудро)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
кйф5
23.07.2020 14:07
Var
  k:longint;
  d,n:integer;
begin
  Write('Введите натуральное число (1-2147483647): ');
  Read(k);
  n:=0;
  while k>0 do begin
    d:=k mod 10;
    k:=k div 10;
    if (d mod 2)<>0 then Inc(n)
  end;
  Writeln('Количество нечетных цифр в числе равно ',n)
end.

Тестовое решение:
Введите натуральное число (1-2147483647): 35632105
Количество нечетных цифр в числе равно 5
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота