Marta2910
08.07.2022 17:25

Напишите программу, которая для заданной точки с координатами (х,у) определяет, где она расположена: на какой оси или в какой координатной четверти

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
GOLUBOVICH0400
22.07.2020 21:26
Pascal

 var   
x,y : integer;    
begin 
readln (x,y); 
if (x=0) or (y=0)
then   
begin   
if x = 0 then
     writeln ('Точка лежит на оси y');   
if y = 0 then
     writeln ('Точка лежит на оси x')'   
end 
else 
 begin 
   if (x>0) and (y>0) then
     writeln ('Точка находится в первой четверти'); 
   if (x<0) and (y>0) then
     writeln ('Точка находится во второй четверти'); 
   if (x<0) and (y<0) then
     writeln ('Точка находится в третей четверти'); 
   if (x>0) and (y<0) then
     writeln ('Точка находится в четвертой четверти');
  end; 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота