SlavZgr
17.09.2020 17:35

Составьте программу, которая запрашивает значение элементов одномерного числового массива a, состоящего из 10 элементов, формирует и выводит на экран в строку данный массив. найти сумму элементов массива, не равных нулю , !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Dinkaakissa20
26.05.2020 04:12

var A:array[1..10] of integer;

i:integer;

s: integer;

begin

writeln('Массив А:');

s:=0;

for i:=1 to 10 do

begin

write('Введите ',i,'-e число ');

readln(A[i]);

if A[i] <> 0 then s:=s+1;

end;

write('Строка чисел: ');

for i:=1 to 10 do

begin

write(a[i],' ');

end;

writeln();

writeln('Сумма элементов, не равных нулю = ',s);

end.

0,0(0 оценок)
Ответ:
ЖаннаLife
26.05.2020 04:12

var

a : array [1..10] of real;

s: real;

k : integer;

begin

s := 0;

for k:= 1 to 10 do

Begin

readln (a[k]);

s:= s+ a[k];

end;

for k:= 1 to 10 do writeln(a[k], ' ');

writeln ('сумма=', s);

End.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота