zaylera34
14.12.2021 23:38

Напишите программу, которая вводит натуральное число и находит все числа на отрезке [0, n], сумма цифр которых не меняется при умножении числа на 2,3,4,5,6,7,8 и 9 (например, число 9). используйте функцию для вычисления суммы цифр числа. паскаль

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
GeorgeWashUSA
22.07.2020 15:37
Var
    n, i, aon_i, k: integer;
    f: boolean;

function AmountOfNumbers(n: integer): integer;
var
    s: integer;
begin
    s := 0;
    while n > 0 do
    begin
        s := s + n mod 10;
        n := n div 10;
    end;
    AmountOfNumbers := s;
end;

begin
    readln(n);
   
    for i := 0 to n do
    begin
        f := true;
        aon_i := AmountOfNumbers(i);
       
        for k := 2 to 9 do
            f := f and (aon_i = AmountOfNumbers(k * i));
        if f then writeln(i);
    end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота