AmooQ
15.02.2023 04:02

Составить программу в с++, печатающую значение true , если указанное высказывание является истинным , и false в противном случае : числа a и b выражают длины катетов одного прямоугольного треугольника , а c и d - другого . эти треугольники являются подобными . на языке с ++

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
palnikov2000
20.07.2020 18:51
#include <iostream>
using namespace std;

int main()
{
    double a,b,c,d;
    cout << "Enter 1st-triangle catheti here: " << endl;
    cin >> a >> b;
    cout << "Enter 2nd-triangle catheti here: " << endl;
    cin >> c >> d;

    bool podobie = ((a/c == b/d) || (a/d == b/c));

    cout << boolalpha;
    cout << podobie;
    
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота