nastea030
08.04.2023 15:22

Написать программу определяющую является ли окружность с радиусом r вписанной или описанной около квадрата

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Shoxrux9818
20.07.2020 07:54
Var
  a,r,rvp,rop:real;
begin
  Write('Введите сторону квадрата и радиус окружности: ');
  Readln(a,r);
  rvp:=a/2; rop:=a*sqrt(2)/2;
  if r<rvp then Writeln('Окружность расположена внутри вписанной')
  else
    if r=rvp then Writeln('Введен радиус вписанной окружности')
    else
      if r<rop then Writeln('Окружность расположена между вписанной и описанной')
      else
        if r=rop then Writeln('Введен радиус описанной окружности')
        else Writeln('Окружность расположена вне описанной')
end.

Тестовое решение:
Введите сторону квадрата и радиус окружности: 8 5
Окружность расположена между вписанной и описанной
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота